RX Update Deployment
Incident Report for Rugby Xplorer
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 23:28 UTC
Investigating
RX deployment.
Posted Sep 02, 2024 - 23:01 UTC
This incident affected: Admin Portal, Rugby Xplorer App, Rugby Match Day App, My Account Portal, and API.