App Deployment
Incident Report for Rugby Xplorer
Resolved
This incident has been resolved.
Posted Nov 17, 2024 - 22:05 UTC
Investigating
RX system deployment.
Posted Nov 17, 2024 - 21:53 UTC
This incident affected: Admin Portal, My Account Portal, API, and Cron Server.