Rugby Xplorer API Release

Incident Report for Rugby Xplorer

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 20:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2026 - 19:51 UTC
This incident affected: API.