Rugby Xplorer Production Release
Incident Report for Rugby Xplorer
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 22:24 UTC
Monitoring
Developers are updating admin and API.
Posted Nov 20, 2024 - 22:08 UTC
This incident affected: Admin Portal and API.