Core Services Deployment
Incident Report for Rugby Xplorer
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 02:33 UTC
Investigating
We are currently investigating this issue.
Posted Sep 06, 2024 - 02:05 UTC
This incident affected: Admin Portal, Rugby Xplorer App, Rugby Match Day App, My Account Portal, and API.