API Deployment - 20min
Incident Report for Rugby Xplorer
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 01:09 UTC
Investigating
We are currently investigating this issue.
Posted Sep 04, 2024 - 00:54 UTC
This incident affected: Admin Portal, Rugby Xplorer App, Rugby Match Day App, My Account Portal, and API.