Rugby Xplorer Access

Incident Report for Rugby Xplorer

Resolved

This incident has been resolved.
Posted May 23, 2026 - 05:22 UTC

Investigating

We are aware of intermittent issues affecting people’s access to RX. We are currently investigating.
Posted May 23, 2026 - 04:00 UTC
This incident affected: Admin Portal, Rugby Xplorer App, and Rugby Match Day App.